1. Home
  2. Edge
  3. How do I create an edge test setup?

How do I create an edge test setup?

Edge set ups are characterized by having computational resources in multiple geographic locations. Staging such an environment in a single lab for evaluation or testing purposes, can be remarkably challenging. In this article we will describe a setup that can be used to build a Bright setup spanning several edge locations, all in a single location.

We will assume that you have a Bright head node up and running using your favorite Linux distribution. For more information about how to deploy a Bright head node, please consult the Bright Installation Manual.

The following diagram shows a basic networking setup that can be used to build an edge setup.

On the left hand side of the diagram there is a core cluster consisting of a head node and a compute node (connected via a private network). On the right hand side there is an edge director with an edge node, connected on an internal network. The core external network (in this diagram 10.2.0.0/16) is assumed to be the network from where you will be accessing the set up. It is quite likely that your lab environment does not use 10.2.0.0/16, in which case you will want to substitute 10.2.0.0/16 with your range. In the diagram 10.2.200.200 is assumed to be the normal default gateway of your network.

The edge router in the diagram plays a central role in routing traffic between the core location and the edge location(s). The easiest way to implement this router is by using an L3 switch in which several VLANs have been created with one IP subnet per VLAN. The switch then acts as a router between these different IP subnets.

The following switch configuration can be used to build a setup such as the one depicted in the diagram:

...
interface vlan1
 description "Lab Network"
 no shutdown
 ip address 10.2.100.100/16
!
interface vlan1001
 description "core cluster internal"
 no shutdown
!
interface vlan1003
 description "edge site 1 internal"
 no shutdown
!
interface vlan1004
 description "edge site 1 external"
 no shutdown
 ip address 10.152.100.100/16
!

interface ethernet1/1/1
 no shutdown
 switchport access vlan 1001
 flowcontrol receive on
!
interface ethernet1/1/2
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/3
 no shutdown
 switchport access vlan 1001
 flowcontrol receive on
!

interface ethernet1/1/10
 no shutdown
 switchport access vlan 1003
 flowcontrol receive on
!
interface ethernet1/1/11
 no shutdown
 switchport access vlan 1004
 flowcontrol receive on
!
interface ethernet1/1/12
 no shutdown
 switchport access vlan 1003
 flowcontrol receive on
!
ip route 0.0.0.0/0 10.2.200.200
...

The configuration above assumes the following port assignments:

port 1/1/1: core head node internal interface
port 1/1/2: core head node external interface
port 1/1/3: core node001 internal interface

port 1/1/10 edge director internal interface
port 1/1/11 edge director external interface
port 1/1/12 edge node001 internal interface
Updated on July 15, 2021

Comments

  1. I can’t find any hardware requirements/hints regarding Edge Director. Edge manual doesn’t help neither. Are there none?

Leave a Comment