Categories

ID #1031

How do I setup the Torque 2.5 package on Bright Cluster Manager 6.0 cluster?

By default, Torque 3.x (name of packages: torque and torque-client) is setup on a Bright Cluster Manager 6.0 cluster.

 

However Torque 2.5.x is sometimes preferred by administrators. It can be installed with the following steps:

  • Make sure no user jobs are executing or queued.
  • Backup your spool directory (usual location: /cm/shared/apps/torque/var/spool).
  • Disable torque:
    wlm-setup -w torque -d
  • Install torque2 and torque2-client packages using yum.
  • Install torque2-client into your software images and propagate the changes to your compute nodes.
  • Setup torque:
    wlm-setup -w torque -m
  • Remove module file for torque 3.x, located in /cm/shared/modulefiles/torque/.

Note: do not remove the torque 3.x package, because the MPI libraries are linked with torque 3.x libraries. If you do remove the torque 3.x package, then you will need to recompile the MPI libraries using torque2 libraries, and then install the new MPI libraries manually.

Tags: torque

Related entries:

You cannot comment on this entry