Categories

Bright Cluster Manager FAQ News  RSS

Python 2 End-Of-Life Notice and Bright Cluster Manager Python 2 End-Of-Life Notice and Bright Cluster Manager

 

Python 2 soon to become unsupported

Python 2 will become unsupported on January 1, 2020 (https://github.com/python/devguide/pull/344 and https://pythonclock.org/). This means that Python core developers will no longer be maintaining the 2.x branch.

 

Consequences and considerations

Python 2 code will continue to run as long as the python executable and libraries are available for the underlying operating system. I.e., it can be kept running as a legacy system as long as you can keep it going. 

However, if you have code in development, or are planning new projects, then you are strongly advised to migrate to the latest Python branch. Currently (July 2019), this is version 3.7. 

In addition, many external libraries have also said that they will drop support for Python 2 (https://docs.scipy.org/doc/numpy-1.14.2/neps/dropping-python2.7-proposal.htmlhttps://github.com/numpy/numpy/pull/12506). Following the advice is therefore a good way to avoid future problems.

 

Code Migration from Python 2 to Python 3

  • The bad news for the migration to Python 3 is that Python 3 is not fully backward-compatible with Python 2. This means that your Python 2 code may fail if you try to run it with Python 3. So, you will probably have to fix your Python 2 source code so that migration is successful.

 

More details on getting your code to run in Python3 can be found here: 

https://docs.python.org/3/howto/pyporting.html

 

2019-07-12 14:39

Upgrades to Bright 8.2 Upgrades to Bright 8.2

It is now possible to upgrade clusters from earlier versions to Bright 8.2. The details about the procedure are in the  Bright 8.2 upgrade instructions at http://kb.brightcomputing.com/faq/index.php?action=artikel&cat=2&id=449&artlang=en

2019-02-21 10:27

CUDA10 packages available for Bright 8.1 and 8.2 CUDA10 packages available for Bright 8.1 and 8.2

CUDA 10 packages are now available for Bright 8.1, 8.2

Installation details are to be found in the manuals:

For a complete update, any older CUDA version must first be removed with the package manager utility.

  

 

2019-02-08 12:22

Mellanox version 4.5 OFED stack available for Bright 8.1 and 8.2 Mellanox version 4.5 OFED stack available for Bright 8.1 and 8.2

The Mellanox version 4.5 OFED stack is available for Bright 8.1 and 8.2. 

Installation details are available in the manuals:

As always, kernel versions must match the stack.

2019-02-08 12:20

Upgrades To Bright 8.1 Upgrades To Bright 8.1

It is now possible to upgrade clusters from earlier versions to Bright 8.1. The details about the procedure are in the  Bright 8.1 upgrade instructions at http://kb.brightcomputing.com/faq/index.php?action=artikel&id=431

2018-07-05 17:30

Show archived news.

There are 305 FAQs online